Errors between Blue Canvas and Salesforce.
Incident Report for Blue Canvas
Resolved
Even-tough Salesforce continues to give random errors, we are marking this incident as resolved.

Our workaround seems effective in resolving these errors in over 99% of the cases. If you still receive this error manually retrying once will most likely resolve the issue. If not feel free to contact support.
Posted May 11, 2021 - 07:22 UTC
Monitoring
We identified the issue. With release 52.0 Salesforce is returning http 500 responses for randomly when we request the profile. This api call is necessary for us to login.

As a workaround we implemented retry mechanism. This should resolve all cases, however we are still monitoring the situation.
Posted May 10, 2021 - 17:50 UTC
Update
We are continuing to investigate this issue.
Posted May 10, 2021 - 17:46 UTC
Update
So far we found strong indicators that this happens when interacting with Salesforce sandboxes.

Errors started appearing last Saturday during the Summer '21 update deployed by Salesforce.

We continue to investigate the situation.
Posted May 10, 2021 - 16:52 UTC
Investigating
Some customers are experiencing errors.

Affected customers will see the following error in the deployment logs:
FATAL: Could not read '.tenantId' from response.

Affected customers are also unable to connect a new organization to Blue Canvas, resulting in "Internal server error"
Posted May 10, 2021 - 16:09 UTC
This incident affected: Metadata Sync (Inbound), Metadata Deploy (Outbound), and Salesforce APIs.