Queue Overloaded

Incident Report for Blue Canvas

Monitoring

We identified the root cause. One of our queued jobs, scheduled to run every 10 seconds, began taking several minutes to complete. These long-running jobs accumulated and consumed all available worker capacity.

We've deployed two fixes:
- Concurrency limit, only one instance of this job can run at a time, preventing pile-up.
- Rewritten algorithm, the job now resolves in ~1 second instead of minutes.

We're continuing to monitor.
Posted Jun 11, 2026 - 16:23 UTC

Identified

A queue that processes background jobs has become overloaded, and is affecting the creation of deployment requests. We're currently working to resolve this issue.
Posted Jun 11, 2026 - 15:37 UTC
This incident affects: Metadata Deploy (Outbound).