Files tab not working in deployment requests

Incident Report for Blue Canvas

Resolved

The incident has been resolved since February 15th, we have been monitoring ever since but the incident has not been properly updated.
Posted Mar 11, 2025 - 15:41 UTC

Monitoring

The queues seem to be cleared up and everything is working as expected. We've had to clear some of the queues. We have not yet identified the exact job that was delaying the system. However we've found some great optimizations and working on a long term fix for those meanwhile we are monitoring the situation.

If your deployment is still showing as "Nothing to merge from" please use "Discard results and validate again" in the top right dropdown of the deployment request view.
Posted Feb 14, 2025 - 11:28 UTC

Investigating

The frontend is not updating properly when rendering the file tab. This is due to a significant boost in background jobs on our git server. We are investigating the root cause.

Deployments are working, but we understand it is hard to see what is going on without being able to inspect the files.
Posted Feb 13, 2025 - 22:01 UTC
This incident affected: Blue Canvas Web Application.